8 EDITING

8.1 Delete Elements

To delete an element, make sure that the entire element is selected, including any visible opening and closing tags.

8.1.1 Simple elements

For simple elements, like left text, selection can be achieved with triple-click + the Delete key or Backspace key.

B8 V4  + Delete / Backspace

8.1.2 Complex elements

For complex elements, select the element with the breadcrumb + Delete key.

byl:content bcl:section bcl:paragraph bcl:text
1 :The followinl officer positions are establist
(ra4) »CNgef Administrative Officer;«

»Director of Corporate Services.«

8.1.3 Outline view

1. To delete an element in Outline view, click in the element in the document to highlight it in Outline View

(raq) PChIef Admlnlstratlve folcer 4
@ bcl:num b

@ bel:text Director of Corporate 5 #Dbd DDIr¢t0r of CDFpOFEItE Services.«

4 @& pcl:paragraph bDirector of Corpor:

2. Thenclick in the top level of the element in Outline view + Delete key:

Lsrerran u

o bal:text Chief Administrative (ra<) +Chief Administrative Officer;«

4 o bd:paragraph bDirector of EEEEEEE——— +Director of Corporate Services.«

3. To select a range of elements, in Outline view click in the first element + hold down the Shift key + click in the last
element in the range + Delete key:
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I @ bcl:paragraph cdogwood;

I @ bcl:paragraph dgarry oak;

I- | @ bcl:paragraph ehemlock;

- @ bcl:paragraph ared maple;
- | @ bcl:paragraph fwestern red

8.1.4 Click and drag selection

1. Inthis example, the section element has been selected with a click and drag action:

»Officer positions:
+The following officer positions are established:«

(ra<)frChief Administrative Officer;«
vDirector of Corporate Services.«

2. Although it looks like the entire element has been selected, when the Delete or backspace key is used to delete the
section, a portion of the element is left behind and a jagged red underline is displayed under the remaining part of
bcl:section element indicating a schema error.

A red lightbulb icon occurs on the left side of the editing window, indicating an error, and a red error bar occurs on
the right side of the editing window.

?  |bcl:section =

3. The error message can be read by clicking on the lightbulb. The messages indicate that the section element is
incomplete and provides actions for re-instating the missing elements; however, the intention is to delete the
section.

¢ bcl:section

© One of the following elements is expected|| Insert the required element o _
- {http://wwnw.gov.be.ca/2013/bclegislationjmargin
<> |nsert element 'marginalnote’ alnote' as last chid.

«> |nsert element 'num’

4. To delete the remainder of the section element, hit the Delete key a second time or click on the section
breadcrumb (which is displayed in red as a result of the error) and hit the Delete key:
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:bylaw  byl:content becl:section

Ibcl:section ‘

— W

8.2 Copy/cut and paste text only
& B2 o

To edit text within an element use the keyboard shortcuts (Ctrl + C, Ctrl + X and Ctrl + V) or Edit toolbar buttons for
Copy, Cut and Paste:

1. Select text + cut (Ctrl + C):

vThe first reading, allgeN=EEiEMsecond reading, and«

2. Paste (Ctrl +V)

»The first reading, second reading, third reading, |and4

8.3 Copy/cut and paste an xml element

8.3.1 Copy/cut and paste element immediately below
To cut/copy and paste an entire element such as preamble text, a section, subsection, or paragraph:

1. Clickin the element, e.g. subsection, then click on the element’s breadcrumb at the top of the document window to
select the entire element:

:bylaw byl:content bcl:section bcl:subsection bcl:text

J

2. Use Ctrl + C to copy the element, and then (if pasting immediately below) use Ctrl + V repeatedly to paste:

»Costs«
1 (+14) »The costss«
(»r14) »The costs«
(»r14) »The costs«
(»14) »The costs«
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3. If required, use Renumber Section to renumber the elements.

8.3.2 Copy/cut and paste to a new location
To cut/copy and paste an element into a new location:

1. Click in the element and then on the breadcrumb to select the entire element, e.g. section:

bylaw byl:content bdl:section bcl:marginalnote
AN PV e Nl

NOW THEREHRDRE the Board o

rResponsibilities«

2. Cut or copy the element, then position the cursor at the end of the last element above the target location:

rAgreements:
2 (»14) »Council delegates«
(ra4) vpurchasing budgeted goods and services;«
(vb4) rroadside litter collection;«

(»24) »Council delegates the power to enter into agreements.|<1

3. Click on Paste:

rAgreements«
2 (»14) rCouncil delegates«
(ra<) rpurchasing budgeted goods and services;«
(*b<) rroadside litter collection;«

(»r24) vCouncil delegates the power to enter into agreements.«

rResponsibilities«
1 The following «
(ra¢) rensure «
(rb4) rensure «

8.4 Paste special - Paste as text in a table cell
The Paste Special action gives you the option to paste text OR paste xml (element + text).

To copy text in a table cell “line” element and paste it into the empty line element in another cell without duplicating the
line element:

1. Triple-click in the text to select all the words in the line element:

CiviX Municipal User Guide, Part 8 Editing, QP Digital Publishing, Victoria, B.C. 4



Increase effective line

line line

2. Copy the selection (Edit > Copy / Ctrl + C / or right-click > Copy):

Increase effegtive Ltina

- EX Add Comment. —
line

a  Edit Attributes... Alt+Enter
Edit Profiling Attributes...

Insert >
& Cut
4 Copy
) Paste Ctrl+V
Paste special >

3. Position the cursor in the empty line element in the next cell, right-click to open the context menu, and select Paste

Special > Paste as Text:

Increase effective lline—
EY Add Comment..

line |

@ Edit Attributes... Alt+Enter
Edit Profiling Attributes...

Paste Ctrl+V

Paste special >
Table \‘I ]

Iramar k]

4. The text is pasted into the empty line element:

Increase effective Increase effective]

line line

8.5 Remove duplicate line tags in a table cell

If a line element has been inadvertently copied into another line element in a table cell, you will notice duplicate

breadcrumbs for oasis:line:

oasis:trow oasis:entryl oasis:line oasis:line

Column 3

$125

line
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To remove the extra line element:

1. Place your cursor in the line element, Right-click to open the context menu, and select
Refactoring > Delete Element Tags

Column 3 Column 4

- line
=Y Add Comment..

] 4 Edit Attributes... Alt+Enter line
Edit Profiling Attributes... line
- Paste Ctri+V
Paste special b
Table >
Images >
Select b
Text >
Refactoring > | +! Togagle Comment Ctrl+Shift+Comma
Review Move Up Alt+Up
Manage IDs Move Down Alt+Down
Insert Rename Element..
Folding Delete Element Tags ~ Alt+Shift+X
Inspect Styles Attributes >
= Options Comments >
Elements b
Fragments >

2. Inthe breadcrumbs, only one oasis:line element is now present, as expected:

oasis:trow  oasisientry oasis:line

|Cn|umn 3

3125

8.6 Paste Special - Paste as XML in a table cell
The Paste Special action gives you the option to paste text OR paste xml (element + text)
For example, to copy a list element in a table cell and paste as XML into the next cell:

1. Position the cursor anywhere in the list element and select the in:ul breadcrumb (inline unordered list):
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oasis:tgroup oasis:tbody oasis:trow oasisientry oasis:line

in:ul insli

Column 2

Column 3

2. Copy the selected element with Edit > Copy (Ctrl + C). Position the cursor at the end of the line element in the target

This is an unordered b

cell. Right-click and select Paste special > Paste as XML.

Column 3

Column 4

Paste the list as xmk

line

-

E¥ Add Comment...

Edit Attributes... Alt+Enter
Edit Profiling Attributes...

Paste Ctrl+V
Paste special ~>
Table >

Paste the list as xml:

Paste as XML
Paste as Text

3. The entire list element + content is pasted into the cell as child of oasis:line

Column 2

Column 3

bullet list:
» apple
* banana
* pear

This is an unordered

» apple
* banana
* pear

Paste the list as xml:

4. Notice the difference if the bullet list is pasted as text only (see second image):

Column 3 Column 4
Paste the list as xml: Thefh

« apple =Y Add Comment...

* banana Edit Attributes.. Alt+Enter

* pear Edit Profiling Attributes...

Paste Ctrl+V

line line Paste special \
line line  Table
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Column 3 Column 4

Paste the list as xml: The apple banana pear
* apple

* banana

8.7 Content Completion Assistant

The Content Completion Assistant displays a list of elements that are allowed in the current editing context (position of
cursor). Content Completion can be especially helpful if you have inadvertently deleted an element, e.g. the “line”
element from a table cel, and wish to re-insert it.

To access the Content Completion Assistant, hit the Ctrl + Spacebar keys.
For example, to re-insert a missing line element from a table cel:

1. Position the cursor in the cel:

|
line

line

2. Hit the Ctrl + Spacebar keys on the keyboard to open the Content Completion Assistant:

New oasis:entry ~
in:br

oasis:line

comment

element
processing-instruction
amd:chars

@ amd:explandescriptor

@ = menl s m m sk

Mew oasis:ent

¢ ¢ & 0 0 @

3. Use the arrow keys to get to the desired element in the list of allowable elements in this context.
When you reach oasis:line, double-click or hit the Enter key to insert it in the table cel.
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New oasis:entry P
@ in:br
@ opasis:line
® comment \
® glement
& processing-instruction
@ amd:chars
® amd:explandescriptor o
& ormdvnwnlannntn
oasis:line

8.8 Remove Text

To remove text from an element while leaving the element intact, use the Remove Text function accessed via the
context menu, with Right-click > Refactoring > Remove Text.

To remove text from an element and its children:

1. Select the element with the breadcrumb. In this example select subsection:

byl:content bcl:section bcl:subsection bel:text
(viii¢) rfor-profit affordable rental housing, and«
(rive) rlow environmental impact development.«

»The revitalization program is intended to accomplish the objectives by encouraging«
(ra¢) rinvestment and development of industrial and commercial land,«

(vb¢) rrejuvenation of mixed use commercial areas, and«
(rce) rconstruction of rental, supportive, and higher density housing.«

2. Inthe area selected, right-click on the mouse and choose Refactoring > Remove Text from the context menu:

@ Edit Attributes... Alt+Enter
Edit Profiling Attributes...

Insert >
& Cut
B o .
1es ¢ o horize«
0 Paste Ctri+V .
ax e . #rsection 2264 of the #++Commui
Paste special >
is B Select >
wvell  Text > ance with #rsection 5634 of the #
Refactoring “ > | #! Toggle Comment Ctrl+Shift+Comma
Review > ove Up Alt+Up
Manage IDs > ove Down Alt+Down
/thi  Folding ? | & BBurround with Tags... Ctrl+E '
Inspect Styles & Rename Element...
©= QOptions <ay@@elete Element Tags Alt+Shift+X
= Remove All Markup
temption available under this ByIE:'@ Remove Text

CiviX Municipal User Guide, Part 8 Editing, QP Digital Publishing, Victoria, B.C.



3. The empty subsection and paragraph elements remain:

(>num <) »text«
(>num <) »text«
(>num ) »text«
(>num ) »text«

8.9 Rename elements, e.g. change center text to subtitle
In a few scenarios, the Rename Element function may be helpful.

In this example, the centertext element has been used to create a schedule subtitle. To replace the center text element
with the schedule subtitle element without losing the content:

1. Click in the center text element content. The centertext breadcrumb is highlighted by a thin blue line:

coa:bylaw byl:content bcl:schedule bcl:centertext
Schedule

|Po|icies and Procedures

2. Click on the centertext breadcrumb to select the element:

coa:bylaw byl:content bcl:schedule bcl:centertext

Schedule

Policies and Procedure

3. Right-click to open the context menu and select Refactoring > Rename Element:

Schedule

=3 Add Comment...
Edit Attributes.., Alt+Enter
Edit Profiling Attributes...

Insert »
Cut
Copy
Paste Ctrl+V
Paste special >
Select >
Text >
Refactoring > | +! Toggle Comment Ctrl+Shift+Comma
Review > Move Up Alt+Up
Folding Move Down Alt+Down
Inspect Styles F  Surround with Tags.. Ctrl+E
@= Options % Rename Element..
<5 Delete Element Tags Alt+Shift+X
2 Remove All Markup
T Remove Text
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4. Inthe Rename Element dialogue, select the Rename current element option (or, if you want all center text
elements changed to schedule subtitle, select Rename all elements with the same name).

Schedule

Rename:; bcl.centertext

bel: centertext '

@ Rename current element

New name

() Rename siblings with the same name

(") Rename all elements with the same name

®

Cancel

5. From the New name menu, select the “schedule subtitle” element:

Rename:; bclicentertext >

N

Mew name

@ Rename
O Rename

O Rename

%)

bcl: centertext

6. Click on OK:

bel:list

bel:part
bel:rightsmalltext
bel:righttext
bcl:schedulesubtitle
bel:section
byl:signatureblock
oasis:table

7. The center text element has been replaced by the schedule subtitle element and the content is preserved:

Rename: bcl.centertext

[T E =l ol - schedulesubtitle

@ Rename current element
() Rename siblings with the same na

() Rename all elements with the same

()

e

Cancel

coa:bylaw byl:content bcl:schedule bcl:schedulesubtitle

rrMayord4

brCorporate Officerd<

Schedule

olicies and Procedures
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